TLS updates needed for Aha! API usage

API callers must support TLS 1.2 connections.  Some common development frameworks and suggested actions are below:

Upgrade needed:

  • Windows Server 2008
  • .NET 3.5 and below
  • Java 6
  • OpenSSL 1.0.0 and below

Configuration changes needed:

  • Windows Server 2008R2
  • .NET 4.0/4.5
  • Java 7

No action is required for:

  • Windows Server 2012+
  • .NET 4.6+
  • Java 8+
  • OpenSSL 1.0.1+

Note that Ruby, Python, and other languages utilize OpenSSL or another TLS library either from the underlying system or installed with the binaries. Please reference the version of OpenSSL or other TLS library on your system in these cases. Please contact support@aha.io if you are concerned your API calls may be affected, however, note that TLS 1.2 support is common in software released in the last five years.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Roadmap software to manage your products.
Finally, connect strategy to execution.

Powered by Zendesk